Algorithm/백준

항해99 리부트코스 알고리즘 1주 - 2일차 2003 수들의 합 2

Albosa2lol 2024. 7. 18. 18:16

https://www.acmicpc.net/problem/2003

 

문제

N개의 수로 된 수열 A[1], A[2], …, A[N] 이 있다. 이 수열의 i번째 수부터 j번째 수까지의 합 A[i] + A[i+1] + … + A[j-1] + A[j]가 M이 되는 경우의 수를 구하는 프로그램을 작성하시오.

입력

첫째 줄에 N(1 ≤ N ≤ 10,000), M(1 ≤ M ≤ 300,000,000)이 주어진다. 다음 줄에는 A[1], A[2], …, A[N]이 공백으로 분리되어 주어진다. 각각의 A[x]는 30,000을 넘지 않는 자연수이다.

출력

첫째 줄에 경우의 수를 출력한다.

예제 입력 1 복사

4 2
1 1 1 1

예제 출력 1 복사

3

예제 입력 2 복사

10 5
1 2 3 4 2 5 3 1 1 2

예제 출력 2 복사

3

 

 

풀이 1 브루트포스

import sys

def count_subsequences_with_sum_bruteforce(A, N, M):
    count = 0
    for start in range(N):
        sum = 0
        for end in range(start, N):
            sum += A[end]
            if sum == M:
                count += 1
    return count

# 입력 처리
input = sys.stdin.read
data = input().split()
N = int(data[0])
M = int(data[1])
A = list(map(int, data[2:]))

# 함수 호출
result_bruteforce = count_subsequences_with_sum_bruteforce(A, N, M)
print(result_bruteforce)

 

풀이 2 슬라이드 윈도우

import sys

input = sys.stdin.read
data = input().split()
N = int(data[0])
M = int(data[1])
A = list(map(int, data[2:]))

def count_subsequences_with_sum_sliding_window(A, N, M):
    count = 0
    start = 0
    end = 0
    current_sum = 0

    while end < N:
        current_sum += A[end]
        end += 1

        while current_sum >= M:
            if current_sum == M:
                count += 1
            current_sum -= A[start]
            start += 1

    return count

result_sliding_window = count_subsequences_with_sum_sliding_window(A, N, M)
print(result_sliding_window)